Somebody please do something about the Galidor games

Discussion of LEGO Games, both online and retail.

Moderators: JrMasterModelBuilder, Sir Guurahk The Third, Bon

Somebody please do something about the Galidor games

Postby Aaron McGee » Tue Dec 30, 2014 6:43 am

I've noticed that this website has a save option for the Bionicle games, but not for the Lego game called Galidor Quest. Can somebody please give Galidor Quest a save, register, and log in just like those Bionicle games? I want to save my progress, come back where I left off, give my player a username, and challenge other players in arenas. If the BIoMediaProject people can give the Bionicle games the option to save, register, and log in, then why can't can't they do the same with Galidor Quest?

Galidor Quest was on from 2002 to 2003. In 2004, got rid of This is what looked like ...

This is the BMP's Galidor Quest ... index.html

Another problem is whenever I enter Boge Attack or a sewer sector, the game freezes, even after I download what BMP wants me to download.

The Galidor game Boge Attack freezes too even after downloading things: ... /game.html

Can someone please find a way to give Galidor Quest a a save, register, and log in option like the Bionicle games? And please fix the freezing on the Galidor games? All the Galidor games are freezing these days.
Aaron McGee
Posts: 3
Joined: Tue Dec 30, 2014 4:04 am

Re: Somebody please do something about the Galidor games

Postby JrMasterModelBuilder » Tue Dec 30, 2014 6:45 pm

Maybe someday. Trouble is, it's a Shockwave game, and unlike Flash based games, there exist no real decompilers or disassembler. The game's saving system is no longer online, so static analysis is impossible. I've probably made greater strides than anyone in reverse engineering the Shockwave file formats, but disassembly into human workable data is still a long way off, and I'm not exactly full of time to work on it.

As for the freezing issue, I'm not sure why that happens. Possibly a Shockwave issue, Adobe has really let Shockwave compatibility go in recent years. If anyone is willing to create a video that shows how to quickly run through the game to get to the part where it freezes, that would be helpful for us to diagnose the problem.
User avatar
BioMedia Project Staff
BioMedia Project Staff
Posts: 228
Joined: Fri May 25, 2012 12:04 am
Location: Central Park, Miniland, LEGOLAND California

Re: Somebody please do something about the Galidor games

Postby owl » Fri Jul 10, 2015 12:29 pm

I think this is another case where the game can only run in Shockwave 8.

Actually, iirc, Galidor games were one of the few games that were best run with Shockwave 8.5 (or was it 9?). I remember that because it broke compatibility with Robohunter 2.

Also, don't know what I did, but I have both Firefox 1.0 and Firebird installed. I uninstalled Shockwave using the uninstaller provided by adobe. my understanding is that it should not have uninstalled Shockwave in Firebird (didn't bother checking).

Long story short, the game as provided no longer works in Firebird (it gets stuck loading). It also does not work in Firefox 1.0. Strangely enough though, the game as provided in the online directory does work. Are there additional files in the online directory?

Some notes about the game:

Playing the boge attack game forces a shockwave error when playing the taskmaster fight. To skip this error, visit the taskmaster via the other tunnel.

Sometimes, some tasks do not appear completed, even if they are. I do not know why.

I do not know how to enter the sewer above a building in downtown Dreejal Vin. Exiting via that sewer tunnel is another story. Either way, that task remains uncompleted.
Posts: 9
Joined: Fri Feb 22, 2013 12:10 pm

Re: Somebody please do something about the Galidor games

Postby triumphbionuva » Sat Jan 21, 2017 1:53 am

This might be a dead topic but I am in need of some help. I found gameplay videos on youtube that date the recording to 2016 and it shows that someone went into the sewers. I read the description that you needed Mozilla Firebird, so I went ahead to find the browser. I downloaded from biomediaproject the browser, shockwave 8, the xtras. but then I get this script error when I try to play it on Firebird.

After I click "Yes" or "No" on it the game freezes and stays on the screen where there are green "i", it doesn't progress. The character that you need to control to choose the difficulty doesn't even appear. I tried every method I could find, I even tried the compatibility settings.(first on win XP service packs 2 & 3 then setting it on 98) but they don't work either. Is there anyway to fix this? this is the only game I have seen that shockwave has failed. Other games like Spybotics Nightfall, on any version of shockwave, works just fine. I may have sent an email about this but just in case that there is no one that can respond to emails(and for explaining the solution to the public) I am posting it here.
User avatar
Posts: 2
Joined: Fri Jan 20, 2017 10:07 pm

Re: Somebody please do something about the Galidor games

Postby greatman601 » Tue Dec 05, 2017 5:56 am

Don't know I can post it or not. Brad MacDonald who designed Galidor Quest game ( I already contact Brad if he has the copy and saving data for that game, but he hasn't reply for a while. Anyways, your best off was to find his resume and to find his contact by phone and to ask him for that game, just to give him an attention.

If not then, maybe get in touch with Wade Tinney ( ... giXQ%3D%3D, and to ask him that. He used to run Large Animal Games. But don't know he can reply or not. I already ask him that, but no reply.

JMMB if your available. Let me know if any can reply.
Posts: 1
Joined: Tue Dec 05, 2017 5:38 am

I got into the sewers!

Postby blep » Mon Jan 08, 2018 2:20 pm

After years of trying to play Galidor again I finally managed to get into the Sewer sectors! I am using Windows 10 64 bit. Using some of the things that worked for other people, here are the steps I took to get there...

NOTE: I had Firefox installed before I began.

Step 1: Uninstalled any existing versions of Shockwave Player from my computer
Step 2: Installed Firebird browser (
Step 3: Installed Shockwave Player 8.5 ( When I installed Shockwave Player, it gave me the option to add the plugin to my already existing Firefox browser, which I accepted. After the installation, the plugin had not been added to Firebird.
Step 4: Manually added the plugin to Firebird by copying the three newly-installed plugin files from my Firefox 'plugins' folder to the Firebird plugins folder.
Step 5: Opened the Firebird browser and tested the shockwave player ( The site should show an image if the Shockwave player is working.
Step 6: There was no image for a few seconds, but then a box popped up from Shockwave asking me to register with a name and email. I put in a fake name and email even though it said that an email would be sent. After refreshing the page, the image was visible.
Step 7: Went to the BMP Galidor Quest page, and after a bit of refreshing the game loaded! It froze a couple of times in random areas, causing me to have to restart a few times.
Step 8: Speed-ran to the institute and successfully got into the Sewer Sectors!

I really hope this works for someone else out there so we can enjoy our favourite childhood game again! :D
Posts: 1
Joined: Mon Jan 08, 2018 1:44 pm

Return to Games

Who is online

Users browsing this forum: No registered users and 1 guest